Go Back   Steve's Digicams Forums > Digicam Help > Add-On Lenses

Thread Tools Search this Thread
Old Jul 17, 2004, 1:49 PM   #1
Junior Member
Join Date: Jul 2004
Posts: 1

Since 2 months my friend owesaCanon 10D. On this body he has mounted a Tamron lens which worked well on his analogue camera for years (12).Before he bought the 10D he was assured by everyone that this lens would work wellon the 10D. Unfortunately, theTamron, Model 171D, AF28-200mm, F/3.8-5.6LD Aspherical (IF) produces unsharp images in any mode except for AE. When aCanon lens is mounted onthe same body the differences are evident. Also compared tothe sharpness of my Sony DSC F828 images.The 'Tamron images' are bad in details and not sharp at all. Not only in 'tele' mode'. An impossible combination or does it require different mode settings or adjustments?
nl26000 is offline   Reply With Quote
Sponsored Links
Old Aug 25, 2004, 10:02 AM   #2
Junior Member
voicebox's Avatar
Join Date: Jul 2004
Posts: 7

Hi there,
Tell your friend to go out and buy a Tamron 28-75 SP AF Aspherical XR Di f2.8 Macro with Canon fit, he will not be disappointed!
This is a terrific lens - I have one mated to my Pentax *istD and I get superb results ... in any mode. I was recently in Tuscany at an Opera festival near Batignano shooting outside/inside at 2am with the lens 'wide open' using ISO 800/1600 - every photgraph is pin sharp!
On the other hand if that lens is too 'short' for him, tell your pal to try the Sigma 70-200 f2.8 - WOW!!
Good luck -- voicebox:-)
voicebox is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:19 AM.