Go Back   Steve's Digicams Forums > Digicam Help > Add-On Lenses

Thread Tools Search this Thread
Old Nov 22, 2005, 5:41 PM   #1
Join Date: Jul 2004
Posts: 63


I am the proud owner of an Olympus c210 telephoto conversion lens which I use with my Panasonic FZ1v2; I attach it using a 55-to-52mm step down ring.

BUT -- the threads on the Olympus lens are so shallow that the darned thing falls off at the slightest bump! Has anyonefigured out an acceptable solution to this problem?

Many thanks for your input!

nmastae is offline   Reply With Quote
Sponsored Links
Old Nov 23, 2005, 10:08 PM   #2
Senior Member
toshi43's Avatar
Join Date: Oct 2005
Location: Vernon BC Canada
Posts: 1,618

The problem is that Olympus lenses are only designed to work with Olympus cameras. Even if you did manage to get the Olympus lens to stay on your camera, I'd be surprised ifit didn't cause unacceptable vignetting at wide-angle settings.

Thread-pitch is standard throughout the industry, ie, alens with 55mm mounting threads will accept 55mm filters and accessories from any manufacturer. Maybe your step-down ring is worn or not quite the right size.

Getting the Panny tele-converter designed for your camera would be the best solution.
toshi43 is offline   Reply With Quote
Old Nov 23, 2005, 10:21 PM   #3
Join Date: Jul 2004
Posts: 63

Thanks for your response. It may well be that my step-down ring is not what it purports to be. I'll try to find another such ring and see if it makes any difference.
nmastae is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:01 PM.