Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Thread Tools Search this Thread
Old Nov 7, 2008, 12:43 AM   #1
Junior Member
Join Date: Nov 2008
Posts: 1

Hi all, I'm new here, sorry I didn't introduce myself like I should around here but I'm in a desperate need of help and advise.

You see, a few days ago I got a brand new Sony HVR-HD1000U professional camera, it works great, but the problem lies within it's built-in battery charger, if I connect the AC adapter into an outlet, the light that indicates the recharging does not goes on, sometimes it does, but it goes off without me doing anything even when the battery hasn't charged up completly, I thought that maybe it was a problem with the cable, but whenever I connect it to my camera when it's on, it will turn off, even though in the user manual it says that you can still operate the camera while it's plugged into an electricity outlet, obviously this is not the case with me.

I can't go back and ask to have it changed because I bought it in the U.S., and I live in Mexico, plus, there's an event that I have to shoot very soon and once the battery runs out I'm truly fu*ked, I could look for a stand-alone InfoLITHIUM battery charger but I don't want to spend any more money on this camera, it was expensive enough as it is, but I would also like to know if there is a way that I can fix this problem.

Sorry this was long, but hopefuly someone will be kind enough to let me know if this is an issue that can be fixed.

Many thanks in advance!.
FargoJ is offline   Reply With Quote
Sponsored Links
Old Nov 9, 2008, 1:02 AM   #2
Senior Member
Join Date: Jul 2005
Posts: 358

Hello Fargo,

When your charging light goes off, remove the battery pack and measure its voltage.

If it is around 8.4 volts, it is fully charged.

SilverFoxCPF is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:17 AM.