Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Thread Tools Search this Thread
Old Jan 9, 2011, 2:00 PM   #1
Senior Member
marcoangels's Avatar
Join Date: Sep 2002
Posts: 243
Default NiZn AA's work great in my SX130!

I bought Canon's SX130 for Christmas and as the reviews say, it "eats" alkakines for lunch! My first pair lasted for 5 photos and one short movie and then the "replace battery" warning came on. My second set of alkalines lasted a bit longer, but not much. I tried some old NiMh AA's and charged them up, only to find that they wouldn't power the camera properly. So, after some research, I tried the NiZn AA's from PowerGenex, which hold a 1.6 volt charge, rather than the 1.2 volt charge that NiMh's hold. What a great battery! It's been in my camera almost 2 weeks now and no sign of weakening. I've read several reviews from other digicam owners and they all agree that this set of batteries functions the best. And they were a steal (around $10) for the charger and 4 AA's at amazon.I'm just amazed at the difference and performance, I've been shooting a lot of HD movies.
PowerGenix ZR-PGX5HRAA-4B, 3-5-Hour Fast Charger with 4 AA 1.6v High Voltage Rechargeable Batteries (Green)
marcoangels is offline   Reply With Quote
Sponsored Links
Old Jan 11, 2011, 10:45 AM   #2
Senior Member
WCKSer's Avatar
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,841

I have the same battery in my old Sony H2, they work great. The H2 eats Ni-MH very fast in this camera. The Genix NiZn batteries solved my problem.
WCKSer is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:16 PM.