Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Thread Tools Search this Thread
Old Aug 24, 2013, 2:47 PM   #1
Junior Member
Join Date: Aug 2013
Posts: 3
Default Nikon D40 all of a sudden not recognizing battery

I've had a Nikon D40 for several years. Used it last night just fine. This morning I turned it on and get a message that says "This battery cannot be used. Choose battery designated for use in this camera" However, this is the original Nikon battery that came with the camera and that worked fine the night before. What's going on?
ladylonghorn is offline   Reply With Quote
Sponsored Links
Old Aug 24, 2013, 3:40 PM   #2
Senior Member
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,691

Assuming you're using the original battery- and thus,is a few years old- let's hope the fault lies within the ageing battery....
SIMON40 is offline   Reply With Quote
Old Aug 24, 2013, 4:02 PM   #3
Senior Member
TCav's Avatar
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,394

One possibility is that, due to the long use, charging and discharging, the battery can no longer power the camera. Given that the battery is the original one that came with your D40, I think this is likely. Have you tried a different battery?
  • The lens is the thing.
  • 'Full Frame' is the new 'Medium Format'.
  • "One good test is worth a thousand expert opinions." - Tex Johnston, Boeing 707 test pilot.
TCav is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:48 PM.