Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Thread Tools Search this Thread
Old Aug 26, 2005, 7:20 AM   #1
Junior Member
Join Date: Aug 2005
Posts: 1

We gave ours to a friend. It used to last 100 pictures with the LED on (as the manual describes); but now they're getting only 10! Every time they use the camera, they have to put more AA batteries in it. And they're good batteries; that's not the issue.

Anyone can think of anything else? Could it be the other battery? Is it dying, so the AA have to be used more? :?
eblackwell is offline   Reply With Quote
Sponsored Links
Old Aug 27, 2005, 9:05 AM   #2
Senior Member
Join Date: Mar 2005
Posts: 1,870

Hard to tell how someone else is using your camera. For example, if you turn on a camera and take 100 pictures in 10 minutes, as opposed to taking 10 pictures over a period of an hour (with the camera tured on), you might have comparable battery drain. I believe the camera was originally rated for 100 minutes run time with the LCD on. I don't know if that was with alkaline batteries, or NiMH's. NiMH batteries would give you a lot more mileage than alkalines - not to mention being a lot cheaper.

I don't believe that a camera would just start using more current because it is old. It would most likely just fail. If they are using NiMH batteries, maybe they are not fully charged.

the Hun

rinniethehun is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:49 PM.