Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Oct 1, 2007, 4:56 PM   #1
Junior Member
Join Date: Jun 2003
Posts: 4

I recently upgraded from a 10d to a 1Ds Mark II. I had the Sigma 24-70 mm 1:2.8 EX DG lens that I had been using with the 10D. When using the Sigma with the 1Ds The focus never seems to be sharp. Its usually just a wee bit short of being sharp. I noticed also when I use my Canon 550 EX flash with the camera and the Sigma lens the zomm function on the flash does not work either. I have read where there are lenses that Sigma had had to re-chip or some such process to make them function properly. The 1Ds works flawlwssly with the 70-200 Canon with Razor sharp focus but just doesnt seem to do it with the Sigma. Any suggestions or opinions appreciated.

thos913 is offline   Reply With Quote
Sponsored Links
Old Oct 4, 2007, 12:35 AM   #2
Senior Member
Michi's Avatar
Join Date: Jul 2003
Posts: 176

I've had my share of problems with Sigma lenses not working on newer Canon bodies. I never did re-chip them, just sold them and stuck with Canon lenses. The problems I had were the aperture not working, or ERR messages coming up in the display and the camera freezing. They would however always focus normal. Do you have any of the other symptoms?

Hm, another thought,doesn't the 1Ds Mark II have a 1.3orfull-frame sensor? Could it be that the 24-70 EX DG is made for 1.6 crop factor cameras? Would that even matter? Just speculating, probably not...

But to sort of answer your question, yes, you can contact Sigma and have them re-chip the lens if they think that will fix the problem. Just send them an email and tell them everything you just told us here.
Michi is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:24 PM.