Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Aug 6, 2009, 8:09 PM   #1
Junior Member
Join Date: Apr 2007
Posts: 4
Default problem with canon XS dslr any ideas????

at first i was getting err 99....
turn camera on and off and it would be fine..

then after 4 to 5 pics you would need to turn on and off to take pics
thing is if you removed the sd card the camera would work fine and take pics no prob at all..

tried 3 sd card all same thing.. now you need to remove the camera battery to be able to take pics after the camera goes into sleep mode. the camera will turn off and the only way to get it back on is to remove the battery and then re-insert. also if left in the camera the battery will completely drain.. it does charge fine and seems to work great unless left in the camera..

its under warranty for 4 more months but i hate to send it in if its only the battery

any ideas??
rangerflav is offline   Reply With Quote
Sponsored Links
Old Aug 12, 2009, 6:56 AM   #2
Senior Member
bmullen@comcast's Avatar
Join Date: Oct 2004
Location: Pennsylvania
Posts: 4,435

This happened to a friend of mine. It stopped after he updated the firmware.
bmullen@comcast is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:51 PM.