Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Dec 26, 2011, 11:15 AM   #11
Junior Member
Join Date: Dec 2011
Posts: 6

One thing that I have noticed lately is in a mode with the flash when the iso automatically sets to 1600 or 3200 the camera stays busy for awhile which prevents it from taking another photo. Is it normal for it stay busy for around 20 seconds give or take?
Poimandres is offline   Reply With Quote
Old Dec 26, 2011, 1:01 PM   #12
Senior Member
iowa_jim's Avatar
Join Date: Jan 2010
Location: North Central Iowa
Posts: 589

Sounds like you are up against the high iso noise reduction feature. The camera has a setting for both high noise photos and high iso photos, if I recall correctly, that will create a bit of processing time after the photo is taken. Like when your iso is at 1600 or 3200.

As you progress in dSLR world and obtain some enhanced software to take the noise out in computer, you might elect to turn off the in-camera noise reduction because the camera is slower at it and not as effective at it.
iowa_jim is offline   Reply With Quote
Old Dec 29, 2011, 7:07 AM   #13
requa's Avatar
Join Date: Jun 2006
Posts: 63

Going forward, if you leave the camera on while you switch to a different lens, you might run into problems with proper control of the new lens (I know I've run into this with attaching a flash). If this happens, just turn the camera off and back on again so that the body will properly recognize the new lens during start-up.
requa is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:54 AM.