Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Apr 4, 2014, 5:03 PM   #1
Senior Member
squirl033's Avatar
Join Date: Dec 2004
Posts: 6,541
Default Tamron 150-600 AF problems?

anyone tried the new Tamron 150-600 on a Canon 7D or 5D Mk II? i'm curious how the AF works in AI servo mode on moving subjects... i've heard reports that this lens doesn't track properly in AI servo, especially at full zoom with subjects moving toward or away from the camera...

Out where the rivers like to run, I stand alone, and take back something worth remembering...
~ Three Dog Night

squirl033 is offline   Reply With Quote
Sponsored Links
Old Apr 7, 2014, 12:41 PM   #2
Senior Member
wave01's Avatar
Join Date: Jun 2010
Location: North West England
Posts: 1,742

I have heard good and bad reviews on this lens so I too would like to know
wave01 is offline   Reply With Quote
Old Apr 9, 2014, 2:56 PM   #3
Senior Member
WCKSer's Avatar
Join Date: Nov 2009
Location: SF Bay Area
Posts: 2,841

I actually have my eyes set on this lens and have been thinking about buying one. I wish Tamron will get on it to fix this problem.
Canon 5D MKII, EF 24-105mm f/4L, EF 50mm f/1.8, EF 100mm f/2.8L Macro, Tamron 70-300mm f/4.0-5.6 SP Di VC USD XLD, Sigma DG 150-500mm f/5.-6.3 APO HSM.
Canon EOS T3i, 7D and 70D EF 17-40mm f/4L, EF-S 55-250mm f/4-5.6, Sigma 18-250mm f/3.5-6.3 DC OS HSM, 430 EXII Flash.
Sony A200, SLT-A58 System with HVL-F42AM Flash.
Mirrorless APS-C camera: Samsung NX100, Canon EOS-M.
M4/3 systems: Olympus OM-D-E-M5 and Panasonic DMC-G3.
WCKSer is offline   Reply With Quote
Old Apr 10, 2014, 3:07 PM   #4
Senior Member
Mugmar's Avatar
Join Date: Jul 2005
Posts: 3,134

I've heard that they have done an update to the lens that is supposed
to fix that issue, have not heard if it really worked or not.
MUG's Flickr

MAR's Flickr
Mugmar is offline   Reply With Quote
Old Mar 24, 2015, 12:39 PM   #5
Senior Member
TD Cole's Avatar
Join Date: Jan 2005
Posts: 1,488

Issues have been fixed on the 2nd generation of the lens and its a sweet lens
Gripped Canon 7D and some glass
FotoZone Facebook Group
TD Cole is offline   Reply With Quote
Old Mar 24, 2015, 7:09 PM   #6
Senior Member
grandpawrichard's Avatar
Join Date: Feb 2009
Posts: 243

I have a Tamron 150-600 lens that I use with my Canon 7D and my Canon 5D Mark II. I have not had a single problem with it so far. Autofocus is Spot on and Fast!

2 Canon 7D Cameras, Canon 5D Mark II Camera, Canon 17-40 F/4 L lens, 2 Canon 24-105 L lens, Canon 70-200 f/4 L lens, Canon 300 f/4 IS L lens, Canon 400 f/4 L lens, Canon 1.4X L extender, Canon 2X L extender, Canon 430 EX Flash, Canon 530 EX Flash
grandpawrichard is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:16 AM.