Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Jun 27, 2004, 9:17 AM   #1
Join Date: Jan 2004
Posts: 89

I have a Sigma 135-400 soom with EOS fit.

If mounted on the 300D, then when set to any apperture other than WideOpen, when you shoot, the mirror flips up, then the camera tells the lens to stop down - and it doesn't. The camera then says "Error 99" and you have to reboot it.

Shooting wide open is a pain coz the depth of field even with targets 50-100 feet away is tiny, I have many shots of fuzzy birds.

BUT the good news is Sigma in the UK will update the firmware for a charge of £33 - which includes sending the lens back to you after they've done it.

(This is not as good as in the US where I hear they do it for free, but OTOH it's lots better than I was told which is that they won't do it at all in the UK.)

Just contact Sigma Imaging in Welwyn Garden City. Takes about ten days.

They say they'll do this with *any* lens for which the updated chips are still available, which should certainly include a current model (as the 135-400 is).

I look forward to sharper birds! :-)

ccomley is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:34 AM.