Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Oct 15, 2002, 1:19 PM   #1
Join Date: Jul 2002
Posts: 37
Default Canon EOS D-60 Flash Doesn't Work

In the short time I've had my D-60, I've used it exclusively for available-light photography.

Now I just tried taking some built-in flash shots but the pop-up flash doesn't pop up, regardless of the basic and creative settings I've used. Pressing the Flash Button on the left side of the camera housing (near the "EOS D-60" logo) doesn't do anything nor does any flash icon appear in the viewfinder.

Did I inadvertently turn off my flash capability? I'm still learning to master the D-60...so I'm open to all suggestions from those of you in the know.

Many thanks.

M i k e

P S - I do recall the flash popping up automatically when I first got the D-60.
shamrock838 is offline   Reply With Quote
Sponsored Links
Old Oct 16, 2002, 4:20 PM   #2
steve's Avatar
Join Date: Jun 2002
Posts: 2,535

The D60's flash is manual, you push the button to pop it up when you want it. It should pop up whenever the button is pushed, even if the camera is turned off. Sounds like a mechanical problem to me.

steve is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:48 PM.