Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Oct 27, 2004, 1:33 PM   #1
Join Date: Aug 2004
Posts: 40

Is this the way dust appears on images? These blobs look large to me, but perhaps this is normal for dust. I circled my blobs.


Attached Images
dcl2q is offline   Reply With Quote
Sponsored Links
Old Oct 27, 2004, 2:41 PM   #2
Junior Member
Join Date: Jan 2004
Posts: 27

Looks like it.

Try shooting a blank wall If you have a zoom lens or more then one lens.

Take more the one pic.

If the spots move in the frame, I think the dust in on the lens, if the spots do not move I think it's on the sensor.

Be careful cleaning the sensor (do a search on how to clean sensor)

I had to clean my 10D before. I have not had to clean my 20D yet, it should be the same procedure.

I have heard that some people received there 20D dirty.

Good luck

RobertL is offline   Reply With Quote
Old Oct 27, 2004, 8:51 PM   #3
Senior Member
Pierre's Avatar
Join Date: Jun 2004
Posts: 335

looks like that its the lens ?????

maybe im wrong but????
Pierre is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:02 PM.