Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Nov 21, 2004, 4:55 PM   #1
Junior Member
Join Date: Nov 2004
Posts: 1

I am looking for any suggestions you may have. I have a new Canon 20D that takes really dark pictures when using any of the auto modes and the built in flash and taking pictures indoors. Even when taking pictures with the subject at 5 or 6 feet the pictures are dark. The firmware is at 1.0.4..not sure if this makes any difference. I am able to make adjustments in the creative modes to correct for the darkness. But I cannot see how the darker pictures would be considered normal for a $1500 camera out of the box. I had the same trouble with the first 20D as this one is a replacement and it is doing the same thing. How can this be considered normal? Have others experienced this same thing??? Thanks for any suggestions you may have. I love the camera except for this aspect and to me this is MAJOR.
Thanks for your help!!!
DonB :-)
odell is offline   Reply With Quote
Sponsored Links
Old Nov 21, 2004, 9:01 PM   #2
Pekkle's Avatar
Join Date: Oct 2004
Posts: 41

Is the flash being reflected by something shiny and confusing the camera?

I was using a 380EX on my 20D yesterday at a motor museum. The pictures came out darker WITH the flash.

Too many shiny bits on the cars
Pekkle is offline   Reply With Quote
Old Nov 21, 2004, 9:33 PM   #3
Senior Member
Join Date: Jun 2002
Posts: 106


I had the same thing happen with my new 20d. The problem with mine was simple, the pop up flash was bad. I didnt know untill a friend taking a sample of me shot a picture and i realized the flash never went off. There is a ambient light beam that did get shot out proir to the expected falsh to go off so i never thought the falsh was the problem. I got it back fixed but was very dissapointed the how it was packaged and sent back. I actully filed a complaint and got it on record just in case it dies in the next few months. I wanted to reply because i know how frustrated you are, i was myself. John
jcarboski is offline   Reply With Quote
Old Nov 23, 2004, 11:34 AM   #4
Join Date: Oct 2002
Posts: 39

Is your entire picture too dark or is a close subject lit and everything around it dark. To solve this type of situation set your camera to use Center-weighted average metering and see if you get the desired results.
jjgncmg is offline   Reply With Quote
Old Dec 3, 2004, 6:55 PM   #5
Junior Member
Join Date: Nov 2003
Posts: 7


I just traded in my 10d for the 20d. The pics I take indoors with the 20d also come out dark. The histogram is heavily scewed torwards the left. My 10d shots always had a nice histogram distribution. My 20d shots are clear but I am asking myself the same question as you, is this normal, especialy since the 10d were much more evenly balanced.
balexsey is offline   Reply With Quote
Old Dec 4, 2004, 5:52 AM   #6
Junior Member
Join Date: Feb 2004
Posts: 1

Odell and all-- You are not alone. Over the past several months, there have been many postings on various boards about underexposure using the built-in flash with the 20D. Also reports that this condition persists even when using the new 580 external flash. I have a 20D and a 10D and the difference is noticable as you pointed out. I believe that this has something to do with the E-TTL II metering/flash system. I, like many others, have found that adjusting flash compensation +2/3 to +1 provides the type of pictures that I am looking for, comparable to the 10D. Not sure yet why the condition exists--- perhaps someone with more techincal savvy can explain that part.
mike67x is offline   Reply With Quote
Old Dec 4, 2004, 9:57 AM   #7
Senior Member
Join Date: Jun 2004
Posts: 184

I had the same problem with my 300D, I now use FEL before taking the picture which seems to have resolved the problem. This doesn't work in full auto mode but does in 'P' mode which is pretty much the same thing.

I assume the 20D has this feature.:lol:


mf_blues is offline   Reply With Quote
Old Dec 4, 2004, 10:35 AM   #8
Senior Member
NHL's Avatar
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,331

Switching the lens mode from AF to M prior to taking a shot will also force the camera to center-weighted metering (instead of evaluative based on the AF points) for flash!

This is the same metering as if the camera is put on manual and the flash exposure will also be much more consistent :idea:
NHL is offline   Reply With Quote
Old Dec 6, 2004, 7:01 PM   #9
Junior Member
Join Date: Dec 2004
Posts: 24

Wow. I just bought a 20D... it'll be here by the end of the week.

I'll have to see if mine does the same thing.

Thanks for the pointers, though! (Gee, do I have a lot to learn....)
Ghostwriter is offline   Reply With Quote
Old Dec 8, 2004, 6:39 PM   #10
Junior Member
Join Date: Dec 2004
Posts: 20


ME TOO !! Thank heaven we can screwup a lot of practice digital images almost instantly to try to teach ourselves how to compromise the meter vs. reality of performance. I remember 25 years ago when I think I spent a couple of weeks and 10 rolls of Kodacolor (and processing costs) to learn that I had a problem of flash/shutter coordination.

Hey one of you "Old Guys" ( ok 'More experienced') please tell me how you get a photo on your signature box? I looked all over the profile page for a place to launch it but can't find the directions for that particular post. Help?:?
The Mayor is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:27 AM.