Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old May 6, 2005, 10:52 PM   #1
Junior Member
Join Date: May 2005
Posts: 11

I bought a Digital Rebel XT with the EF-S 18-55 lens. Everything appeared to be working fine with the camera for the first few days. This week I borrowed a Tamron telephoto lens from a friend. While the lens will autofocus properly and appears to take photos correctly, the information that is displayed inside the viewfinder and on the information LCD on the back of the camera is garbled. Instead of seeing the aperture and shutter speeds in the viewfinder when depressing the shutter half way, all of the lines and digits flash and have nonsense characters displayed. This same problem appears on the LCD in back where all of the information is garbled so no camera settings, pictures remaining, or other information can be read. This makes utilizing the functions of the camera impossible.

The problem does not occur with the EF-S kit lens so I thought perhaps it was a function of this lens. Today I received a brand new Canon EF 50mm/F1.8 II lens and the exact same problem has occurred. The characters are garbled in the viewfinder and on the LCD though the lens appears to autofocus and take pictures as normal.

Has anyone else had an experience with this kind of problem, or is it expected to happen like this? If there is something wrong (which it appears to me must be the case) is there any fix known other than returning for a new one?

thanks for any feedback
russperry is offline   Reply With Quote
Sponsored Links
Old May 7, 2005, 1:03 AM   #2
Senior Member
G35Guy's Avatar
Join Date: Apr 2005
Posts: 323

I haven't seen that particular problem raised before. I would call Canon support, they're usually quite good.
G35Guy is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:30 AM.