Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Mar 11, 2006, 6:44 PM   #1
Junior Member
Join Date: Dec 2005
Posts: 2

I was shooting with my 10D this afternoon.after 2-3 shots.. my camera gave me a error 99 right after a shotit then locked up.. i had to turn it off then on to regain functionailityfrom that point it locks up after every shutter.it will take the shot.. but not show up on the lcd. and then lock up error 99Ive heard cleaning the contacts.. might help..I have two lenses.. a EF 70-200 2.8 non is and a 14-70 F4i cleaned the contacts on each. and on the camera.. the camera will lock up with either lenses..i swaped out the memory card for another.. and still the error 99 lockupI removed my grip and put the standard single battery.. incase this made a difference.. and it didnti also tried to take a shot with no lens, and no memory card.. (set the options so it would take a shot.) it still locked up error 99right now my 10D is basicly useless if i cant get around this error..please if anyone has any suggestions.. ive searched around and havent been able to come up with any ideas on what i can do..last resort will be taking it to canon.. id rather not.. as i dont have much money to fix it. and dont know how much it might cost
adamfilip is offline   Reply With Quote
Sponsored Links
Old Mar 11, 2006, 9:01 PM   #2
Senior Member
NHL's Avatar
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,331

Try a 'new' battery (or different) battery
NHL is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:25 PM.