Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Thread Tools Search this Thread
Old Jul 10, 2002, 10:50 AM   #1
Junior Member
Join Date: Jul 2002
Posts: 1
Default Cleaning D60's image sensor

I've been using my D60 for about 2 months now. Recently I've noticed several dark, round spots on all of images. One of them is a small hair-shaped mark, the rest just round dots. I used sesor-cleaning option in MENU of D60 which let me blow air (using standard hand blower) directly onto a sensor. This cleared some of the spots but most of them still appear on the images. I can see some dust marks on the sensor still and I can't get them off with just blowing air. Any recomendations on what I should do next?

KPWawelski is offline   Reply With Quote
Sponsored Links
Old Jul 10, 2002, 11:22 PM   #2
Senior Member
Join Date: Jun 2002
Posts: 117

There is a product called <a href="http://www.photosol.com/swabproduct.htm">Sensor Swabs</a> and a solution called Eclipse that dries fast, no residue. They are made by a company called Photographic Solutions, Inc., 508=759-2322. I've cleaned my D30 with them and also my 1D. Swabs are pricey.


[Edited on 7-28-2002 by steve]
icarus is offline   Reply With Quote
Old Jul 15, 2002, 4:55 AM   #3
Join Date: Jul 2002
Posts: 44

try the SpeckGrabber..... just got mine and am happy to say it is getting good reports and it's under $10


[Edited on 7-15-2002 by Jim C.]
Jim C. is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:03 PM.