Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon Lenses

Thread Tools Search this Thread
Old Nov 8, 2006, 2:14 PM   #1
Join Date: Oct 2005
Posts: 36


In my efforts to get a high quality lens on the cheap, I bought an adapter to fit a Pentax 50mm f1.4 lens to my Canon 400D.

Unfortunately, although the image is sharp in the viewfinder, when I take the picture, it is out of focus. I used a tripod and self timer, so it is not camera shake.

I would love to be able to use this lens as it is pin sharp, even wide open.

Does anyone know what is going on and if there is any way to correct it?
luceberg is offline   Reply With Quote
Sponsored Links
Old Nov 9, 2006, 6:12 PM   #2
Junior Member
Join Date: Oct 2006
Posts: 28

hiya, i believe that when you shoot with M42 adapters the ring does not touch the camera body's lens contacts, so the body dosnt activate focus confirmation. Although your viewfinder might be tack sharp, if your shooting wide-open your DOF is so small that its very hard to get tack-sharp focus in the final picture manually. you could get an adapter which fools the camera to give you AF-confirmation with M42 lenses and the AF confirm is more accurate than the eye:


This AF confirmation enabled adapteris an emulator of Canon EF auto-focus lens. It is an electronic device that will"trick"the EOS cameratoactivate its focus confirmation indicator. Thus improve in manual focusing speed and accuracy.

http://cgi.ebay.com/AF-Confirm-Enab...yphotoh osting

I'm a Pentax user, so my camera body provides this feature for me..

Alternatively, I am currently looking at a split-screen viewfinder replacement from Katz Eyes which have a rangefinder style prism. I'm currently waiting one to be available for my K100D =)
sho33y is offline   Reply With Quote
Old Nov 9, 2006, 7:17 PM   #3
Join Date: Oct 2005
Posts: 36

Thanks sho33y,

Maybe it is my manual focusing which is out after all. As you say, it is very tricky to focus accurately wide open.

I think I will give the focus confirmation gizmo a try.

luceberg is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:41 AM.