Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon Lenses

Thread Tools Search this Thread
Old Aug 19, 2011, 12:40 PM   #1
Junior Member
Join Date: May 2005
Posts: 5
Default Canon Lens Problem

I have a Canon EFS 17-85 lens.

I recently started getting the following error message when I try to take a picture using this lens in either my 7D or 40D cameras:
Err 01
Communication between the camera and lens is faulty. Clean the lens contacts.

I cleaned the lens contacts several times using isopropyl alcohol with a cotton swab. I also cleaned the contacts on my cameras. I also tried cleaning the lens contacts with a rubber pencil eraser. The problem remains.

All of my other lenses work normally in both cameras.

I assume the lens is no longer under warranty as it's 6-7 years old.

Any suggestions on where I should go from here?


PMokover is offline   Reply With Quote
Sponsored Links
Old Aug 22, 2011, 3:39 AM   #2
Senior Member
wave01's Avatar
Join Date: Jun 2010
Location: North West England
Posts: 1,742

It looks like a call to canon and gt an estimate to get it fixed. You can then look at that price against a new lens
wave01 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:17 PM.