Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon Lenses

Thread Tools Search this Thread
Old Jan 24, 2012, 9:28 PM   #1
Junior Member
Join Date: Jan 2012
Posts: 4
Default Canon XSi with Sigma 70-200 f/2.8 issue

I recently purchased a Sigma Sigma 70-200mm f/2.8 EX DG HSM II Macro Zoom for use with my Canon XSi. The primary purpose is for taking both indoor (basketball) and outdoor (football) pictures of my son. After the first couple of outings taking indoor pictures in a gym, I am finding that the pictures all seem to be slightly soft and with a slight blur. After trying a test between the kit lens that came with the camera (a 55-250MM f/4-5.6 IS), I called Sigma.
They indicated that this is a known "issue" that is easily fixed if I send in both the lens and my camera so that the lens can be adjusted to my camera. Has anyone gone this route? I like the price and build quality of the lens (a Canon L series is a little out of my price range for purely recreational picture taking). I'm a little uneasy about sending my camera off. Also a little concerned in that I only have a week or so to be able to return the lens for a refund. If the "adjustment" of the lens does not work, I may be stuck with it.

Anyone else been down this path with Sigma?

kylesbigdog is offline   Reply With Quote
Sponsored Links
Old Jan 25, 2012, 6:05 AM   #2
Join Date: Aug 2004
Posts: 8,528

Lens / camera calibration is not a new thing. But, here's the thing:
Sigma will run some tests. They can determine the lens is out of tolerance and make some adjustments. Or, they can determine THEIR lens is working fine but the CANON camera is not.

If you bought the lens new then I would suggest returning it for a new one.

This is a great example of why people like the microfocus adjust feature several DSLRs have now. But in canon it's only available on the 7d and above.
JohnG is offline   Reply With Quote
Old Jan 25, 2012, 7:10 AM   #3
Junior Member
Join Date: Jan 2012
Posts: 4

Thanks for the response. I have used both the "kit" lenses I bought with the camera as well as a borrowed Canon L series without any issue at all. I think I'll return it for something else.
kylesbigdog is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:17 PM.