Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jun 12, 2003, 7:40 AM   #1
Junior Member
Join Date: Jun 2003
Posts: 1
Default Powershot G1

My Powershot G1 has gone poof suddenly. I can't recharge it. I hooked up the recharger with battery in the camera and there is no blinking light, nothing. I can't find the box it came in and can't find the darn manual either. What is the warranty on this camera? I bought it 2 years and 3 months ago. I should have gotten that extended warranty from my credit card. :?
srolen is offline   Reply With Quote
Sponsored Links
Old Jul 2, 2003, 5:18 PM   #2
Junior Member
Join Date: Jul 2003
Posts: 1

Hello, My son had what sounds like the same problem, his G1 just froze up. It happened when it was on, so the lens would not even
retract. There is a firmware update that I applied to his G1, and
now the problem is resolved. I think it had something to do with
the battery being allowed to go completly drained, so that there
was nothing available to even shut the camera down. The result was that the camera was completly useless.
The url for the firmware is:

Hope this helps!
Janetk is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:11 PM.