Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Apr 4, 2007, 7:29 PM   #1
Junior Member
Join Date: Apr 2007
Posts: 2

I found this forum through this thread: http://www.stevesforums.com/forums/v...mp;forum_id=15

My problem is a bit different, the thread is old, and the solutions in that thread did not work for me so I'm starting this new thread.

I was over 200 pictures into a 2GB Kingston 50X SD card when all of a sudden I got an error message. When I tried to view my pictures it said "no data." I had used the card several times before with no problems. However, I had never taken more than about 30 pictures before w/o offloading them and then reformating the card. I can't download the photos from the camera to my computer. Likewise, an SD reader acknowledges the card but doesn't show any files or directories. It doesn't show it empty either though. The card had plenty of empty space when it crapped out.

Anyway, I'm on vacation so I use my other SD cards. The next one I take 150 pictures with and have no problems. I swap it out just to be safe even though it has tons of space left.

I forget to change my next card (4GB generic) and it craps out after about 220 pics with tons of space left. I'm able to offload more than half of the pics but many, very important pictures I cannot access.

I continue to put in new cards on my vacation with no further problems since I change them all out before hitting 200 pics.

1) Why can't I take more than 200 pics or so even when I have loads of space left w/o this problem occuring?
2) MORE IMPORTANT! How can I get these pics off the SD cards? They are incredibly important to me.

http://www.artplus.hr/adapps/eng/dpr.htmdid not work for me.

I contacted Canon and their worthless help center told me to forget about them and reformat the cards.
casea is offline   Reply With Quote
Sponsored Links
Old Apr 5, 2007, 7:54 AM   #2
Senior Member
Tom LaPrise's Avatar
Join Date: Oct 2004
Posts: 324

I have nothing to offer about why the problem is happening.

I've used PC Inspector Smart Recovery (free, but files are all given generic names i.e. CONVAR001.jpg, etc.) to recover pictures I've accidentally deleted from my card. I'm not sure it will help if the file allocation table or memory is corrupt as opposed to space being marked as available, but it might be worth a try. (You have already tried a program of this type and it didn't work, so don't get your hopes up too high.)

Also, try running ScanDisk or whatever disk-checking utility you might have to see if there might be errors it can fix.
Tom LaPrise is offline   Reply With Quote
Old Apr 5, 2007, 8:50 AM   #3
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,370

You may want to this utility using a card reader with the bad card. It ignores the file system entirely and attempts to locate and reconstruct files by looking at header information.


Personally, I run it from Linux to take XP out of the equation entirely.

As for the corruption, are you formatting the card via the camera's menu choice for format prior to each use? If not, I'd make sure to do that.

JimC is offline   Reply With Quote
Old Apr 5, 2007, 9:56 AM   #4
Junior Member
Join Date: Apr 2007
Posts: 2

I am formatting the cards via the camera. I've probably formatted six or seven cards a total of about 40 times since purchasing the camera in January. The only times I've had a problem are the two times I've mentioned and those were the two times that I took the largest number of pictures on a single card without offloading the pictures and then reformattingso I'm guessing that the large number of picturesis the problem and not the cards themselves or the formatting. This appears to be the problem for others as well. My suggestion is to never take more than 200 pictures on a card even if it is a 2+ GB card with loads of extra room even after 200 pictures/video.
casea is offline   Reply With Quote
Old Aug 21, 2007, 4:55 AM   #5
Senior Member
Join Date: May 2006
Posts: 181

Count me in on this. My Cason S3 IS fried my SanDisk Ultra II. Now it won't recognize in anything.
itsme000 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:03 AM.