Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Apr 7, 2007, 5:20 PM   #1
Junior Member
Join Date: Oct 2004
Posts: 9

Well, this is my second andlast Canon disposeable digital camera! Had the dreaded E18 error come to visit my 2 year old A75 for no reason. I did not drop it or expose it to dust, sand, etc. The camera just won't turn on and displays E18. Lots of web info. but none of the tips worked. Looks like eBay for this one too.

This is not my first experience with dead Canons. Had purchased a great little G1 in 2001. It died of the "blown surface mount fuse" issue that Canon has also refused to accept responsibility.

Take my advise and DON'T spend much on any brand of digital camera. This includes the DSLR's. They just are not built to last very long!

prop guy is offline   Reply With Quote
Sponsored Links
Old May 2, 2007, 7:11 PM   #2
Junior Member
Join Date: May 2007
Posts: 4

See http://e18.bitnet.cx/comments.php

Lots of people geting this error, even with recent models like the sd900. Very sad, I was about to pull the trigger on an SD1000 after my s230 died with this error, figured they MUST have fixed this by now, nope.
wakkawakka is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:32 PM.