Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Apr 27, 2007, 3:05 PM   #1
Junior Member
Join Date: Apr 2007
Posts: 1

My S400 has been a great little camera, but now every picture is shadowed in pink. I reset the defaults, and still get pink pictures. Does anyone have any ideas?


Attached is a picture of my "pink" dog.

Attached Images
pvand is offline   Reply With Quote
Sponsored Links
Old Apr 28, 2007, 1:07 AM   #2
Junior Member
Join Date: Mar 2007
Posts: 22

Hmm im not completly sure but I think you might have a problem with your image sensor. I hear Canon had a huge problem with malfunctioning sensors but I assumed they got that fixed, but maybe not. I got a 4 year old A60 that has the same problem but much more distorted and the guy at the dealer said they WERE sending them to canon and getting them fixed for free. Id try calling your dealer beacuse they should know the sensor situation quite well or check this forum later becuasesome canon guy will surly know and reply (sorry that guy aint methough haha)
batrug is offline   Reply With Quote
Old May 6, 2007, 9:57 PM   #3
Junior Member
Join Date: May 2007
Posts: 1

Check out the sticky in this forum about the Canon Service Industry. My S400 started having a very similar problem recently (not exactly the same, but I could see your problem being related to mine). I had given up hope, but posted something on dpreview, and someone gave me the link to the CCD info page. I called Canon and they sent me a label to ship it back to them. Even though it's far out of warranty, if it is the CCD problem, they will fix it for free. The number to call is in the sticky. Good luck!
seren8 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:01 PM.