Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old May 2, 2007, 8:26 PM   #1
smartin's Avatar
Join Date: Apr 2007
Posts: 33

As I am the keeper of the camera, I am also the keeper of the images. Here at home, I share out my camera folder on the LAN so my wife can get to the camera images.

When the Canon S3IS entered the scene, it was not long before we noticed that she could not view certain images. The icons for the JPGs show up in Explorer, but some thumbnails fail to render. If she tries to open these images (e.g., using Irfanview) she gets an error about not being able to read the file header.

Tonight I narrowed down the problem somewhat: Across the network, my wife cannot view any image taken in portrait orientation. Shots taken in landscape orientation are fine for her.

Here's the extra weird thing: I have a web server (IIS) running on my machine. The web server cannot read any untouched S3IS image. If I place any untouched S3IS image in a certain folder where my server looks for images, the server simply does not see the file at all.

Now, if I open an untouched camera image and save it again, say with Irfanview or PSP, the new image appears fine everywhere.

So, my conclusion at this point is there is something wonky about Canon's treatment of JPG. Resaving an image in another application appears to "reset" the headers in some way that makes it viewable.

Any ideas of what's going on here?
smartin is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:42 PM.