Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jun 11, 2007, 7:30 PM   #1
Junior Member
Join Date: Jun 2007
Posts: 1

Hi All,

My GXT Secure Digital Pro card is giving me errors when I insert it into my computer's internal multimedia card reader and also my Canon SD600 camera. I can't get it to work. I've tried restarting my computer and my camera. It still doesn't work. So I only had it for 6months and therefore within the entitlement of the 1 year warranty. I tried a search for the company to contact them but I can't seem to find it. Has anyone ever claimed the warranty and if you can you please forward the information so that I can contact them. Also if you have any suggestions to fix this problem, wether it might just be a temporary problem.

daisybaby is offline   Reply With Quote
Sponsored Links
Old Aug 26, 2007, 6:33 PM   #2
Junior Member
Join Date: Aug 2007
Posts: 1

I am having the exact same issue with my GXT Digital Pro 4GB Compact Flash card. There are sections of the card that are in error and so the card cannot store images in those sections, causing read/write errors. I just got this card in June 2007 and now I want to find out how to claim the warranty and I cannot find details of this company on the Internet.

Anyone have any ideas?


VannLake is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:57 PM.