Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Dec 22, 2003, 6:29 PM   #1
Junior Member
Join Date: Dec 2003
Posts: 2
Default Canon A70 Not as bad as some say

I joined group just to post the following 2 cents worth. Many users have complained of soft images or poor resolution with a Canon a70. At first I suffered through this until further investigation. The REAL problem is extremely minor camera shake--not poor resolution. The Canon A70 is pin sharp. The problem is that on the auto mode which most people use the a70 will in many, many cases set a camera speed lower than 1/60 of a second. I can hold the camera still at that speed , but I think many people can't--especially when they don't know it is set at that speed. Test if for yourself. Put the camera on a tripod and see what your pictures look like--pin sharp. Even in some of the semi-manual situations the speed will be set very slow and people coming to digital after using film are not used to the camera making such crucial settings so low.
BTW I think the digitized sound of a shutter opening and closing is worth the price on the Canons.
Halide_no is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:30 PM.