Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jan 12, 2014, 8:51 PM   #1
Junior Member
Join Date: Jan 2014
Posts: 1
Default Canon SX50 spot metering

When I select spot metering on my Canon SX50 it defaults back to centre weighted average if I switch the camera off and back on again. Is this normal? Does anyone else's do this?
John In Ireland is offline   Reply With Quote
Sponsored Links
Old Jan 13, 2014, 2:25 AM   #2
Senior Member
Hawgwild's Avatar
Join Date: Mar 2006
Location: Pensacola, Florida
Posts: 3,466

Hi John. I have the SX40, which is similar to the 50, and your question got me to investigating. What I found was as you have already discovered, you lose the spot meter setting when you are shooting in P,A,S, or M, and power off the camera. The C1 and C2 settings on the selector knob will allow you to program a set of settings, including spot meter, that will not disappear when you power down the camera. I hope this helps you somewhat. The C setting is for a group of ( Custom settings ) you shoot with most commonly, and are able to access quickly without fumbling around with knobs and buttons when you need to be shooting.
Always use tasteful words - you may have to eat them.
You cannot find knowledge by rearranging your ignorance.

My Flickr

Hawgwild is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:28 AM.