Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Mar 25, 2004, 9:05 PM   #1
Junior Member
Join Date: Mar 2004
Posts: 1
Default Help!!!

Our Canon A70 that we use at our school has developed a problem.It gives us this message in both camera and view mode...memory card error. I have formatted it...hasn't helped. I have tried other cards....same error message. These same cards work fine in our other cameras. Has anyone ever run into this problem with any Canon?[[/quote]
bogeyboy2 is offline   Reply With Quote
Sponsored Links
Old Mar 26, 2004, 7:51 AM   #2
Senior Member
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,402

I have a Transcend 512MB flash card the gives an error just about every other exposure in my Canon G5. I've also heard of folks with other camera brands having compatibility problems with certain brands. Then I use my Sandisk & never have a problem. I don't think that type stuff is too uncommon. I thought after a while if I just reformatted the card that might isolate the problem in the Transcend card, but it still persists. I'm about one more problem away from throwing it away, which is too bad considering it cost me almost $200 back when I bought it, but what good does a card do you if you cannot rely on it to work right? From now on it's Sandisk or Lexar cards for me.
Greg Chappell is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:32 PM.