Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jun 21, 2004, 6:48 PM   #1
Junior Member
Join Date: Jun 2004
Posts: 14


I bought the Canon PowershotS60 at June 15th and Igot it at 17th. I bought it off online since it was not on sale at any retail stores around me. What i noticed by the time I recieved my camera was that there was a little ding along with a small paint chip at the top of my camera. Also, the camera body squeaked as i press anywhere near the shutter release. Worst of all, I got a camera with a stuck pixel in the CCD. Everytime I take a picture, there is a noticeable white spot no bigger than 4 by 4 pixels on the picture. Stuck pixel might be a common problem to any digital cameras, but I already have determined to return the camera by the time I saw that annoying ding and squeaking sound. I wonder what was up with Canon. The camera seemed like it was a reconditioned(refurbished)camera.I was more suspicious because I bought it online, and the camera was not on sale to any other retail stores(such as Bestbuy). I was wondering... did I get the pre-production product?? :?
secondtime is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:20 AM.