Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jun 22, 2004, 9:01 AM   #1
Junior Member
Join Date: Jun 2004
Posts: 1

I just bought a used canon G2. It was tested ok before I purchased it but now at home after a few shoots & on/off camera power. Things started to happen.
1) Lens got struck (just move a few mm out from case) during power up. Truning switch on & off do not help. Have to take battery to reboot the camera before the lens could retract to case and power up again.
2) Next, during power up, the lens moved out totally. But the frame countdown display does not show up (every other info displayed) so no photo shoot can be taken. A few seconds later, camera power down by itself & power up again by itself. Only now, all info are displayed and shoot can be taken.
3) After repeated tried, the camera function as normal again.
The camera is about 1yr 3mth old, runs on IBM microdrive (340mb). Battery display shows battery fully charged.
Can anyone advise if it is a common problem or this is an exception? Or am I operating the camera in a wrong procedure? Do you share the same problem?
Please help and thank you.
Nico Chen is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:19 PM.