Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Nov 5, 2004, 8:51 PM   #1
Junior Member
Join Date: Nov 2004
Posts: 1

As per the title, I bought a canon A75 yesterday. I also bought a set of NiMh batteries that I charged last night.

The camera worked pefectly last night! I only used it for a few test shots.

Anyway, now the camera (with either the regular batteries they were supplied with or the fully charged NiMh) the camera won't turn on at all!

Q: the battery cover seems a little off, though it closes, the battery open switch doesn't quite go back into it's position on the left, kinda just stays in the middle. perhaps this could be the problem
Q2: If I plug the camera into the computer via USB, should lights come on (it doens't detect on my Windows XP system, i haven't installed the software since I have a card reader.)


Matt Lawson
MedievalMan is offline   Reply With Quote
Sponsored Links
Old Nov 6, 2004, 10:06 AM   #2
Junior Member
Join Date: Oct 2004
Posts: 9

1-My PowerShots would act that way when batteries are low, lens won't retract stops in a mid position. Always came back to life if I replaced with fresh batteries even a set of alkaline will do. Be sure you observe polarity as shown on the bottom of case next to tripod mount. You could also leave batteries out a an hour or so sometimes that helps if logic get fussy.

Also you have to hold the power switch in for few seconds then it should wake up.

2- Yes the driver has to be installed before itfullyplugnplay. All usb devices need driver of some sort it's just that some devices are included with XP (mouse), keyboards, etc.

Good luck..
OverTheHill-CA is offline   Reply With Quote
Old Nov 7, 2004, 10:20 PM   #3
Junior Member
Ashwyn's Avatar
Join Date: Oct 2004
Posts: 3

Ans1: There seems to be some problem with your battery cover, the switch usually slides to the left.

Ans2: When you plug-in the camera into XP system and turn it on, the XP will automatically detect the camera and ask for the application you want to use to download the pictures. If you install Canon Wia driver then your camera will blow a blue light at the print/share button.
Ashwyn is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:47 PM.