Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Dec 29, 2004, 2:12 PM   #1
Junior Member
Join Date: Dec 2004
Posts: 1

I bought this A75 a few days ago and after about 100-150 shots the problems started to appear. The thing is that the flash won't fire. I am using NiMH 2200mAh batteries, which are fully charged,andI am quite sure that the flash is set on. I have usedvarious combinations of settings, and it fired only once or twice. When I tried to take a shot with the same settings again,the flashdidn't fire! Is this because of the bateries, or the camera broke?
Veseli is offline   Reply With Quote
Sponsored Links
Old Dec 29, 2004, 4:47 PM   #2
Senior Member
Join Date: Sep 2003
Location: Dallas, Texas USA
Posts: 6,402

Using the 4-wayrocker switch, click on the upper (flash mode) button until the lightening bolt is what you see in the top of the LCD. This means the flashwill fire every time, no matter the lighting situation. Ifit fails to fire everytime once turned on, you have a problem.

If you have the combination lightening bolt and letter "A" that means it will only fires the flash if lighting conditions warrant it's use. The other option as you dial through the flash modes is to turn the flash completely off, meaning it never fires.
Greg Chappell is offline   Reply With Quote
Old Dec 30, 2004, 8:19 AM   #3
Senior Member
Join Date: Nov 2004
Posts: 935

yah...just do what greg says and set the camera to fire the flash every time....just to see if the flash is ok.

The other thing you can do is to get in a very dark place. Turn the camera on. Set it to automatic shooting mode and then take pictures in the dark. If the flash doesn't fire, then something's wrong.
Kenny_Leong is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:48 AM.