Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Aug 17, 2005, 6:29 PM   #1
Junior Member
Join Date: Aug 2005
Posts: 1

Hello all,

Just wondering if any fellow Ixus 50 / Digital Elph SD400 owners could confirm the noise from my new camera is normal. After each zoom step and turning the LCD display off a clicky almost graty noise is emitted. I'm imagining this is something to do with the focussing etc. but it's quite loud and I'm suprised it's not mentioned in the manual (the tiny noise made by the orientation sensor gets a mention which is dead quiet in comparison!)

Also having problems with a SanDisk 1Gb SD card and memory card error, unidentified image and corrupted data errors, seems the card is boogaloo which is rather disappointing.
CrispyUK is offline   Reply With Quote
Sponsored Links
Old Oct 19, 2005, 6:48 PM   #2
Junior Member
Join Date: Oct 2005
Posts: 1


I have came across another user with another brand 512MB SD card. Although no problems reported with a 64MB SD card.

Please keep me posted about what happens, will you send product to Canon?
LondonPhotoRetail is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:50 PM.