Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jan 17, 2006, 9:51 AM   #41
JockScott's Avatar
Join Date: Dec 2005
Posts: 83

Found this on Canon's "Support Page"

"When camera does not operate with a brand-new alkaline battery (for cameras that use AA-size batteries) or with a fully charged rechargeable battery, the terminals may be dirty.
Polish the terminals with a dry cloth and make sure the terminals are clean. If the terminals are covered with oil from your skin or similar matter, this may cause poor contact and power may not be fully supplied to the camera."

1. Even charged battery packs discharge slightly over time. If you have not used the battery pack for a while, we recommend that you charge the battery pack before using it again.

2. If you have not used the battery pack for an extended period of time, or if you are using the battery pack for the first time, it may not be fully charged. Fully charge the battery pack and then discharge it completely in the camera several times to bring the battery pack capacity to normal.

3. Polish the terminals with a tissue or dry cloth before charging the battery pack. If the terminals are dirty, for example if there is oil from your skin on the terminals, this may result in poor contact and the battery pack may not charge fully.

JockScott is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:13 AM.