Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Feb 26, 2008, 7:22 PM   #131
Junior Member
Join Date: Feb 2008
Posts: 2

I believe that I am actually having the same problem with my S2 IS. I know it's not on the list, but has anyone else had this happen? I can see pictures that are already on the card and the menu/display information, but the background is just black.
joshbegin is offline   Reply With Quote
Old Mar 1, 2008, 6:06 AM   #132
Senior Member
gwei's Avatar
Join Date: Apr 2005
Posts: 120

My A610 recently died, the same problem.
gwei is offline   Reply With Quote
Old Mar 20, 2008, 2:05 PM   #133
Junior Member
Join Date: Jul 2005
Posts: 3

My S1 died recently with this problem, sadly it was the day before I left for vacation. My kids had their own cameras so not having it was not the end of the world. I sent it in for "repair" and was thrilled to find that Canon sent me an S5 (yes, S5) in exchange. (inbox, looks new)They had been sending out S3's but i guess they ran out (others on the S1 Yahoo Group had also reported this recently). Amazing!
misterbill is offline   Reply With Quote
Old Apr 11, 2008, 9:51 AM   #134
Junior Member
Join Date: Apr 2008
Posts: 1

For those of you who had this CCD problem with a resulting black screen: did the shutter open when you took pictures?

I am asking because at first my camera A80 had these distorted images, later on it went completely black. I took the camera to the local service center, here in Estonia, where they told me that some kind of a wire is broken in the optics part and the whole lens has to be replaced. The cost would be 235€.

I remember that the zoom worked, but when i would take a picture it wouldn't open the shutter (i can see it when i shine light into the lens). It just saves a black picture and judging by the time it took to take pictures and the usage of flash, it was using settings for very low light.

some of the pictures it took, before going completely black, were OK, others came out like these:
uibo is offline   Reply With Quote
Old Apr 23, 2008, 6:09 AM   #135
Junior Member
Join Date: Apr 2008
Posts: 5

There are hundreds of people complaining about this on the net. If you google sony s2 is you will come up with them very easily.

So far, as far asI know, Canon is not recognizing the problem with the s2 is, although some persistent people have managed to get a free repair. It seems to happen around the 15-16 month period, so it's just out of warranty.

For all the complaints I've heard about Canon customer service, in my experience they are still better than Panasonic and Sony by far.
herbfellows is offline   Reply With Quote
Old May 27, 2008, 4:10 PM   #136
Junior Member
Join Date: May 2008
Posts: 1

My A610 CCD died the first week I owned it. Black screen with icons and menu displaying okay. It was the week I was leaving on a trip, so I ran out and bought another camera and returning the A610 got put on the back burner. It wasn't until I started reading about all of the A610s that had this problem, that I sent it back to Canon last week. I don't hold out much hope but it seems as if they should include the A610 in their service advisory. How do we let them know about all the Canon
CCDs that are failing? :x
cadjak is offline   Reply With Quote
Old Oct 21, 2008, 9:52 PM   #137
Junior Member
Join Date: Oct 2008
Posts: 1

This is an update to the Powershot S2-IS CCD issue which has been ongoing.
My Canon S2-IS started showing signs of classic CCD failure after my last trip to South Asia. Since Canon has a service advisory out for the S1-IS, I thought my camera would be repaired FOC. I was asked to send in the camera and was sent a repair charge for $128. I refused since I still think it is Canons fault.
However, my story ends happily. This is what I did. I contacted the Better Business Bureau and filed a complaint against Canon. Today I got a call from Canon and was given the one time free "courtesy repair." The procedure is exceedingly simple. Use this link to get to the http://welcome.bbb.org or go directly to the complaint page directly https://odr.bbb.org/odrweb/public/GetStarted.aspx. Go ahead and describe the problem to them and also Canons stance. Explain that the S2 has the same signs of CCD failure as the S1 and it is still not included in the recall advisory.
If enough of users get to Canon via the BBB they will feel the pressure and get off their ...
verticalcobra is offline   Reply With Quote
Old Nov 22, 2008, 10:10 AM   #138
Junior Member
Join Date: Feb 2005
Posts: 10

Seems you guys are far luckier than I, my S1IS died with the ccd problem as confirmed by Cannon. I sent mine to them and it was returned repaired, not replacedwith an S3 or an S5, simply repaired and sent back to me. Oh well.
jimb823 is offline   Reply With Quote
Old Jan 16, 2009, 4:58 PM   #139
Junior Member
Join Date: Jan 2009
Posts: 1

Wow, I just stumbled onto this board and topic. My A80, the best camera I have ever owned, went outlast year (Christmas of 2007)with the LCD blurry issues. For some reason, I never got rid of the camera. It has taken thousands of pictures and it always delivered a crisp, clear shot and the macro functions were awesome. I contacted the 1-800 number and Canon is sending an email and a shipping label to send it to them. Now I hope I get it back, NOT a replacement. I have been tempted to buy a used one it was such a good camera.
Wyatt is offline   Reply With Quote
Old Mar 30, 2009, 6:08 AM   #140
Junior Member
Join Date: Mar 2009
Posts: 2

Ixus 400 purchased December 2003 just gone on me.

As with some of images posted, all images are now pink with hundreds of horizontal white/pink lines across.

It actually started laying up last summer when we went to Florida (Disney), when some pictures showed pink instead of white.

At the weekend, it took 4-5 good shots, then they went to the pics with pink in the white areas, to completely pick with white lines.

Phone Canon UK (overseas call centre) who after 5 mins on hold, told me it was a known issue with the camera and it could be fixed FOC. She gave me the number of Lehmanns Direct who when I called, instantly recognized that it was a Canon CCD issue and told me to send it in. Should take a couple of weeks.
W1zz is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:13 AM.