Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Oct 18, 2005, 10:05 AM   #1
Junior Member
Join Date: Aug 2005
Posts: 4

I switched from the A75 to the A520 because my A75 had died. The A75 had 4 batteries and the A520 has 2. I am constantly having to switch the batteries on the A520. It's getting to the point of annoyance.

Is there something wrong with my camera or is that how all A520s work?

If I needed another Canon, is there a better one you'd recommend?


squirrel is offline   Reply With Quote
Sponsored Links
Old Oct 18, 2005, 10:39 AM   #2
Junior Member
Join Date: Oct 2005
Posts: 6

I would have bought the A520 when I purchased mine, but I could only afford the 510 at the time.

As for the battery problem, I can take a couple hundred pics before I need to swap batteries and I use manual settings all the time, which reduce the battery life.

Are you using NiMH? Have you "refreshed" the batteries lately? Sometimes a low charge will drain the battery faster. To refresh, your charger may have arefresh setting or you couldjust keep the batteries in a device with the power on until they die completely. I always keep a fresh set fully charged at the ready.
northernbillsfan is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:45 PM.