Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Feb 20, 2003, 12:30 PM   #1
Junior Member
Join Date: Dec 2002
Posts: 8
Default S45 Problem - please advise

I exhausted myself and everyone I know when I was deciding which camera to purchase. After much research, I chose the Canon S45. When it works, I love it, but that is not often. Please let me know if you think my camera is a lemon or if there is a problem with the CF card I am using.

When reviewing my photos on the LCD screen, it often says that the image is corrupted. This has happened several times and I figured there was something wrong with the CF card (Viking 256MB card). I exchanged the card (another Viking 256), however I am still having this problem. The LCD either has the error message of CF card error or something about the image being corrupted. I have lost some great pictures because of this and I am very frustrated.

Please let me know if you think I might be doing something wrong or if anyone else has had this problem. I know it sounds like the CF card, but could both card be defective? Please advise. Thanks!
imr5191 is offline   Reply With Quote
Sponsored Links
Old Feb 21, 2003, 12:31 AM   #2
Join Date: Aug 2002
Posts: 51

I use a San Disk CF 128 and Generic no name 512 and have never had a single issue with either of them o my s45. The factory 32 also works fine. you may have a bad camera or CF card. Great camera though.
serpa4 is offline   Reply With Quote
Old Feb 23, 2003, 7:15 AM   #3
Junior Member
Join Date: Feb 2003
Posts: 7

I would tend to lean toward a problem with the card. Have you tried going back to the original Canon Flash card for a few days? If that works without issue, I think you could emliminate the camera as a part of the problem.

Another forum I read often had a G3 user with a Viking 256mb card that was getting similiar errors. A user on that fourm asked the following... "I have been told, on good authority, that after downloading a CFC to NEVER format with the computer but ALWAYS format with your camera. It is possible to "corrupt" the card with the computer.

I know for a fact that you should NEVER try to remove a CFC from a card reader or your camera while the card is still "reading". This can "corrupt" a card."

Best of luck-
rkuite is offline   Reply With Quote
Old Feb 23, 2004, 1:49 AM   #4
Junior Member
Join Date: Feb 2004
Posts: 1
Default Corrupted data S45

I am having this same problem with my S45. This has happened twice to me, once on a trip to hawaii.. which is not a great place to be having problems with your new camera. This happens After about 50 L1/superfine jpgs on a 512 sandisk cf, I will switch to review the last shot... and will be greeted with a corrupt data warning. After the trip I noticed I was getting bad sectors on the CF card in a reader after I formatted it. I called sandisk and they swapped out the card for me, problem solved right? NO! Now six months later at our baby shower I get the same error! It seems to happen when I quickly switch from shooting to reviewing, or at least maybe that is when I notice it. I am calling canon tomorrow morning. :x
collin is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:23 PM.