Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old Jan 1, 2006, 11:47 AM   #1
Junior Member
Join Date: Jan 2006
Posts: 3

Hi all. This is my first post. Excuse me in advance if for any mistakes. Anyhow, I have a Canon Powershot A20. A very reliable camera which took (past tense) great photos from my trips all over the world.

This past Xmas day, I tried to squeeze out a couple extra pictures despite a red battery warning. I recharged my batteries and now the camera seems to operate, but I get nothing on the LCD screen or on the CF card when I take a picture. I can though see the menus as well as photos already on the card. The flash still operates. So I believe the video chip is hosed. I tried totally powering the camera down & pulled the tiny battery out. That only reset the date & time. I went to the Canon web site & it appears repair will be a little over $100. So that tells me it's time for a replacement.

The Canon Powershot A620 seems to fit all my desires: AA's, SD card, optical view finder, all-in-one, and easily carried. So before I make a plunge, I just wanted some feedback on my A20 & perhaps assistance in ressurecting it. I am very capable in repairing virtually anything electronic. I'm not familiar though with digital camera repair.
TonyTrey is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:20 AM.