Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Canon

Thread Tools Search this Thread
Old May 25, 2003, 3:03 PM   #1
Junior Member
Join Date: May 2003
Posts: 5
Default Canon 10D just died

I suspect the battery was very low. The camera has operated flawlessly with three different canon lenses on it. I happened to not pay attention to the battery indicator when I powered it up for a shot this morning.

It appears that the battery died shortly after it lifted the mirror/prism to do the exposure. All I got was a "clunk", and the LCD went blank. I swapped the battery out, but no sign of life anywhere. I managed to take almost 100 shots yesterday during a short period of sunlight between monsoons here in Charlotte. Camera has not gotten wet.

Naturally, the "we replace" warranty where I bought the body is a minor problem because they haven't seen any additional bodies in 4 weeks.

Is there some combination of operations to reset the camera?


Bill Blomgren, Charlotte NC
BillBlomgren is offline   Reply With Quote
Sponsored Links
Old May 26, 2003, 12:04 AM   #2
Senior Member
Join Date: Dec 2002
Posts: 5,803

That is really scarry. I'm going to have to watch out when I get my 10D that I am very careful about batteries.

I looked in the pdf manual I downloaded and I saw no way to reset the camera in hardware. You could probably remove both the main battery and the smaller battery (and keep them out for a little while... 10 minutes? You want all caps to be discharged completely.) I bet that keeps your settings and custom fuctions stored, if nothing else. But if your problem is mechanical (the mirror) then I would be surprised if this would help.
eric s is offline   Reply With Quote
Old May 27, 2003, 7:39 PM   #3
Junior Member
Join Date: May 2003
Posts: 5
Default Such is life..

Exchanged email with Canon.. and ended up taking the critter back to Best Buy...

Hopefully it will be exchanged in the next couple of weeks.

BillBlomgren is offline   Reply With Quote
Old Jun 29, 2003, 3:27 PM   #4
Junior Member
Join Date: May 2003
Posts: 5
Default The 10D is still at best buy...

With the bodies hard to come by, they still have mine. Apparently it went back to Canon for repair. They've now had it longer than I did... (Total time I had it? about 3 weeks. They've had it a month now.) It's very frustrating, but semi-understandable.

When I talked to Canon, they said it would take 2-3 weeks to repair, depending on parts availability. So who knows how long this is going to take????

Hopefully, they will get another shipment of the critters in the near future. I'll be contacting them all next week to see if something walks in. If it does, the manager has promised me a new body to replace mine. Spending real $$$$ on a "service plan" when the repairs may take months is a tad outrageous.
BillBlomgren is offline   Reply With Quote
Old Jul 1, 2003, 8:29 AM   #5
Senior Member
Join Date: Aug 2002
Posts: 610

Well, that is the risk you have to take when buying electronic toy, service plan is a good insurance policy to consider when your basic warranty runs out. BB performance plan is good, 4 years for $99, anything wrong with the camera they will relace with the new one (the only problem is: 10D is almost or never available in stock for a while)or give you full credit for it, they don't have facility to repair digital camera.

Hey, my Nikon F2N still works even the battery died, the only draw back is that I have always carry a spare battery for my handheld light meter...cheers
tuanokc@hotmail.com is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:16 PM.