Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Thread Tools Search this Thread
Old Dec 23, 2003, 7:34 PM   #1
Junior Member
Join Date: Dec 2003
Posts: 2
Default Exilim Z4 problems, answers greatly appreciated

Just sent this letter to Casio, and wondering if anyone here might be able to answer them as well. You must excuse that I'm lazy and did not change the letter so it suitet this situation. Merry Christmas btw!

"Hello, I bought an Exilim z4 for a few weeks ago, I am however experiencing some problems with it and would like to know whether it simply is that way or if it might be some problem that have occured during production.

The "problems" I experience are:
1. When I am indoors the cameras white balance won't relly work, the picture on the display gets very red, the same goes for pics taken without flash. Instead I have to manually set it to tyhe lightbulb icon under the white balance-menu.

2. The cameras autochoosing of settings as good as ALWAYS wants the flash to be used, even if i have put an item on a white desk and is holding a lightsource right over it so it gets REALLY light.

3. When I try to take pictures indoors without flash, and the room/object is very well enlightened, the picures gets both very "corny/sound/lots of "disturbance"" and they are VERY blurry. The camera also wants to use the shutter speed 1/8 even though the room is enlightened, and for some reason these pictures even gets very DARK!

Merry Christmas
Greetings /Jonas Hombert"
azazulz is offline   Reply With Quote
Sponsored Links
Old Dec 30, 2003, 8:05 AM   #2
Junior Member
Join Date: Dec 2003
Posts: 1

Hi there!
I also own this camera, and also have this problem with the WB!
I sugest u to use the BestShot and make some predefined situations for the WB, like indoor,outdoor with sun or snow!
And the u will get rid of this problem!
Hope i helped u!

nem66 is offline   Reply With Quote
Old Jan 1, 2004, 6:38 PM   #3
Junior Member
Join Date: Dec 2003
Posts: 2

Okay really thx, I greatly appreciate the answer!
Will try to configure my own Best Shot-configurations first thing tomorrow

Cheers, enjoy!
azazulz is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:08 PM.