Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Thread Tools Search this Thread
Old Jun 20, 2005, 4:22 PM   #1
Senior Member
The_Other_One's Avatar
Join Date: Jan 2004
Posts: 112

Just a minute ago I was messing around with my Z50 outside. I've had it for about a month now and it's been great. However, just recently, it locked up on me. I was walking around looking for a good shot when I saw the screen cut off. I pressed a button to get it going again, but it wouldn't come back on. I pressed a few buttons to powre it, but nothing happened(the lens was still out too) I finally just popped the battery out then back in. After a second, it kicked in. The lens retracted then came back out. Since then, it's been ok(posted a couple pics in the closeups) I exchanged my Dimage Xt for this one. The Minolta served me great so I hope this one isn't going to give me problems

Any clue as to what it might of been doing? Oh, battery was fine. It might of just dropped down one bar. Still used it for a while after it locked up and I got it going again...
The_Other_One is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:14 PM.