Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Thread Tools Search this Thread
Old Aug 26, 2005, 12:23 PM   #1
Join Date: Jul 2005
Posts: 51

Hey, Steve finally reviewed it!!! And he likes it. Interesting how oppinions varry, I guess that's why we got a few sources

c0mrade is offline   Reply With Quote
Sponsored Links
Old Aug 26, 2005, 7:56 PM   #2
Junior Member
Join Date: Jul 2002
Posts: 23

A good review. The only thing I'm left wondering about is what version the firmware in the camera was. I could not find this anywhere if in fact it does exist.

Casio has posted version 1.01 I believe and it was designed to fix a bug causing some sort of the picture quality issue/s (softness) in movie modeand another issue with saving your last settings for white balance.

Can firmware even fix soft image results during post processingor is this totally a lens qualityissue?

Steve if you see this can you let us know which firmware version your test s500 had? If it was 1.00 could you tell us if 1.01 helps picture quality in any way?

Thanks and keep up the good work!

EDD is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:14 AM.