Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Casio

Thread Tools Search this Thread
Old Jul 31, 2006, 11:01 AM   #1
Junior Member
Join Date: Jul 2006
Posts: 1

Did anyone experience this issue:

My z750 suddenly stop working, it will not turn on.

I've tried the following:
- removing the battery for a few minutes and place it back in
- when placed in the cradle, the charge light does not turn on
- press the USB and Photo buttons on the cradle and nothing happens
- tested the battery voltage, it was fine

Any ideas??
retroman80s is offline   Reply With Quote
Sponsored Links
Old Aug 1, 2006, 3:29 PM   #2
Join Date: Jul 2006
Posts: 57

call tech support...of just exchange it
aspire is offline   Reply With Quote
Old Aug 1, 2006, 9:04 PM   #3
Senior Member
Join Date: Oct 2003
Location: Indian Rocks Beach, FL
Posts: 4,036

If the battery isn't charging it could just be dead. A lithium battery is dead to the camera while it still has some voltage. If you are testing close to 3.7 volts it should run the camera though.

The failure of the cradle could indicate a power problem to it. I guess it is possible that the processor in the camera died and the cradle won't give any indications.

A remote possibility is that the connection to the battery is bad. That is almost impossible if you have only one battery and don't usually remove it.

If you could find a store that displays the camera in an active cradle you might ask them if you could try yours in it. I would think a Z850 cradle would work too.

Your best bet is probably Casio support.

slipe is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:10 PM.