Go Back   Steve's Digicams Forums > Printers > Dye Sublimation

Reply
 
Thread Tools Search this Thread
Old Feb 19, 2005, 5:11 PM   #1
Junior Member
 
Join Date: Feb 2005
Posts: 1
Default

I have had my 8500 printer for almost 2 years and I am having constant problems with it. Usually it is something I can work through. Despite the fact that every single print I make gets jammed I now can not get rid of lines in my prints. I have tried to print a completely black picture to see if I can find the same line on the ribbon and I have. I have gone though the entire printer and cleaned it and still the line is there. Is it the thermal head making this line or could it be the ribbon? In the past, a few prints have come out with this line and works it self out after 2-3 prints. I have printed over 10 images in a row and it still has not gone away. The line is very small almost the thickness of a hair. If it could be the thermal head, how much would it be to replace it. Does the head have a "life expectancy" because I have almost 1200 prints with this printer (almost all have jammed as well). I have e-mailed about the jamming in the past and nothing has come from it. Sometimes, very rarely, can I push print on my computer and it comes out with out a jam. Although the support guys have been extremely helpful, nothing seems to solve any of my problems.

(this is the same thingI e-mailed kodak soI just copy n pasted it to save time!!!)

Any advice at all would be very helpful. I am thinkig about just getting the 1400 when it comes out but I am sorta turned off now after all the problems I have had with this one.


kelz969 is offline   Reply With Quote
Sponsored Links
Old Jul 1, 2005, 1:02 PM   #2
Member
 
Join Date: Mar 2005
Posts: 66
Default

kelz969 wrote:
Quote:
I have had my 8500 printer for almost 2 years and I am having constant problems with it. Usually it is something I can work through. Despite the fact that every single print I make gets jammed I now can not get rid of lines in my prints. I have tried to print a completely black picture to see if I can find the same line on the ribbon and I have. I have gone though the entire printer and cleaned it and still the line is there. Is it the thermal head making this line or could it be the ribbon? In the past, a few prints have come out with this line and works it self out after 2-3 prints. I have printed over 10 images in a row and it still has not gone away. The line is very small almost the thickness of a hair. If it could be the thermal head, how much would it be to replace it. Does the head have a "life expectancy" because I have almost 1200 prints with this printer (almost all have jammed as well). I have e-mailed about the jamming in the past and nothing has come from it. Sometimes, very rarely, can I push print on my computer and it comes out with out a jam. Although the support guys have been extremely helpful, nothing seems to solve any of my problems.

(this is the same thingI e-mailed kodak soI just copy n pasted it to save time!!!)

Any advice at all would be very helpful. I am thinkig about just getting the 1400 when it comes out but I am sorta turned off now after all the problems I have had with this one.

Replace the head cost $410.00 plus tax, (if you purchased a extended warranty ($159.00 for 1 year) maybe you had not problem, but now cost $410.00 plus tax, or buy the new 1400 at $499.00. call Kodak support and ask them, that ia mayor repair and that is the flat rate for this.

good luck ( Iplan buy my warranty the soon i get money, I don't want to run with this problem, this is great printer for loss it. aHHHh i forget, if you try to buy the head for install you self cost $1495.00 more that the printer costtttt, incredibleeeee!!!!!!!

sorry.

amatheu
AMATHEU is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 6:37 PM.