Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Thread Tools Search this Thread
Old Nov 12, 2006, 1:57 PM   #1
Junior Member
Join Date: Oct 2006
Posts: 4

:?Hello folks, this problem may be too unique to my camera but I thought I'd ask it anyway. My G2 and 420EX flash are not cooperating properly. 8 out of ten photos taken are overexposed due to the full blast of theflash. I don't know if it's a coincidence or not, but sometimes I can wiggle or push on the external flash and get it to fire at the correct exposure. I have thoroughly cleaned all contacts with alcohol. I took both to a camera store and they tried the flash on another camera and it worked flawlessly. They said send the camera for repair. As one can imagine it is not likely worth it to spend a couple hundred dollars on a G2 at this point in time. I was basically hoping there might be someone out there with the knowledge to help me trouble-shoot this problem. I am an electical-tech and am not scared to open the camera if it may require it.

Any ideas my fellow photo enthusiasts?

mb571 is offline   Reply With Quote
Sponsored Links
Old Jul 25, 2007, 1:30 PM   #2
Junior Member
Join Date: Jul 2007
Posts: 1

I've got the exact same problem. Anyone heard of this? Is there a solution?
pbluescript is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:24 PM.