Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Thread Tools Search this Thread
Old Oct 27, 2003, 11:10 PM   #1
Junior Member
Join Date: Oct 2003
Posts: 2
Default Canon G3 and Vivitar 2800 flash

I recently bought a Canon G3 digicam. I have a Vivitar 2800 flash (non-TTL, single pin) and cannot get it to work with the camera. The G3 seems to know it is there because the flash button becomes deactivated. When I take a picture, the charge light is turn off but no flash. I set camera to manual mode with 1/60 shutter spreed.

Any suggestions or is this flash just not compatible?

hpatlik is offline   Reply With Quote
Sponsored Links
Old Oct 28, 2003, 5:29 AM   #2
Senior Member
Join Date: Aug 2002
Posts: 1,910

You're not the only one who has had this problem, others on the net describe the same problem. The main problem is the voltage on the flash pin is TOO HIGH for the G3 (most digitals like a maximum of 10 volts while this flash has been reported to be 140-170 volts; the 2800-D is 4 volts).

From http://www.botzilla.com/photo/strobeVolts.html

"140-170V, according to Bart Van Oudenhove,
though Paul Durant reports his new one measured 20V.
Dave Senciall says his G3 wouldn't fire his 140V version,
and Jack Benson reported his 2800-D (same model?) returned only 4V..."
Mike_PEAT is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:56 PM.