Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Thread Tools Search this Thread
Old Nov 21, 2009, 11:56 AM   #1
Junior Member
Join Date: Nov 2009
Posts: 2
Default maxxum 5d and HVL-F36AM severe overexposures

I have tried everything I can think of to get this flash to work, but it seems that it is not working properly. I have to tilt the head up to vertical to take a shot indoors. If I try a night shot outside it has really long exposures, like 4 seconds. Flash fires every time, but it seems like the metering is way off, and the exposures are not adjusted for the flash firing. I have changed every setting I can come up with, but to no avail. I can control the flash manually, but I bought this flash because I didn't want to have to do that.

It is like I am not getting preflash metering, the camera calculates and fires like there will be no flash, flash fires and washes out all my pics.

If I run the F36 wireless with the popup flash triggering it, everything looks pretty good.

It is like my camera is not detecting that it is going to fire the flash when it is in the shoe.

I know someone has had or heard of this in the past, anyone remember how to fix it?

I have the same result with a minolta D lens, and a SONY 100mm 2.8 macro.

BTW this is my first post...Yay!!
shaun9801 is offline   Reply With Quote
Sponsored Links
Old Nov 21, 2009, 2:03 PM   #2
Senior Member
VTphotog's Avatar
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,165

It sounds as if the flash and camera are not communicating. First thing to check would be the contacts on the flash and the hotshoe. Try cleaning flash contacts with standard rubber eraser (not the ink eraser type,as it is a bit too abrasive). The contacts on the Minolta hotshoes are a little harder to get to, but you might try a cotton swab dampened with rubbing alcohol.
The fit of the flash to the camera may be a bit off. Try wiggling it around on the shoe a bit with the camera and flash on, to see if you get the flash indicator.

VTphotog is offline   Reply With Quote
Old Nov 21, 2009, 2:31 PM   #3
Junior Member
Join Date: Nov 2009
Posts: 2

Good idea!!!So I went and rounded up stuff to clean it, and when I looked at the bottom of the used flash I just bought from B&H I realized that one of the pins was slightly bent, and not comming out all of the way, so I straightened it, and gently pulled it out the rest of the way so it was the same height as the other pins, and took a pic of my daughter's face at about 2-3 feet. Flash fired, Perfect exposure. Can't believe it was so simple. I think I am going to keep the flash, even thought I would love to jam it down B&H's throat since they rated it a 9/10. Oh well. It works now. Thanks for making me look in a different direction.
shaun9801 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:12 AM.