Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Thread Tools Search this Thread
Old Mar 7, 2004, 11:20 AM   #1
Junior Member
Join Date: Mar 2004
Posts: 2
Default help! is the canon 420ex supposed to be so noisy?

I just bought the canon 420ex to use with my canon g3. I'm a total amateur so I just set everything to auto. I dont know why sometimes the flash flashes and sometimes it doesnt. It is pretty noisy, kind of like a charging up noise...is it defective? thanks
aznfayeth is offline   Reply With Quote
Sponsored Links
Old Mar 7, 2004, 1:00 PM   #2
Senior Member
Join Date: Feb 2004
Posts: 209

When you have the camera set to fully automatic, the camera will decide when to flash and not to flash. If you want to make that decision yourself, turn it to P for program mode, then you can decide yourself. Also, I wouldn't worry too much about a charge-up noise.
LTBerry is offline   Reply With Quote
Old Mar 9, 2004, 9:27 PM   #3
Senior Member
Join Date: Dec 2003
Posts: 3,748

I'd be inclined to agree with LTBerry. My 420 pops and fizzles but only because it's gulping for more light. My Sigma doesn't make as much noise and I "did" notice the difference, but both work fine and I think that's just the nature of the beast.
Normcar is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:36 AM.