Go Back   Steve's Digicams Forums > Digicam Help > Flash (External)

Thread Tools Search this Thread
Old Oct 6, 2004, 7:50 AM   #1
Junior Member
Join Date: Sep 2004
Posts: 5

I bought the Olympus C 770 partially because of its hot shoe. Now I am having a hard time finding a 3rd party flash unit or even a flash trigger to work. Does anyone have any ideas or directions to pursue?

thanks, john the toymaker

toymaker is offline   Reply With Quote
Sponsored Links
Old Oct 6, 2004, 10:14 AM   #2
Senior Member
Mikefellh's Avatar
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707

There's a few issues which I'll hit one by one:

If you can't get an external flash to work properly on the hotshoe, it could be that you damaged it by using an old flash that has too high a trigger voltage; many flashes had a voltage exceeding 100 volts on the hot foot, my Starblitz which operated on 2AAs had a voltage of 227V...many digicams like no more than 6V on the hot foot. Some resources:

With manual or automatic (non-TTL) flashes (the type that only have one pin on the bottom), the C-7xx has to be in M (Manual) exposure mode. With these flashes you have to set the shutter speed and exposure to the chart on the back of the flash. There's a section called, "Using commercially available external flashes" in the reference manual that's on the CD that came with the camera.

With Olympus-TTL flashes (Olympus brand or third party), you don't need to worry about all that...the camera and flash talk to each other and you don't have to worry about settings, or compatibility.

Here's a list of flashes that can be used with the C-7xx:
Mikefellh is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:35 AM.